import re
regex = re.compile(r"^(arn:(?:aws|aws-cn|aws-us-gov):[\w\d-]+:[\w\d-]*:\d{0,12}:[\w\d-]*\/?[\w\d-]*)(\/.*)?.*$", flags=re.MULTILINE)
test_str = ("arn:aws:sqs:us-east-1:123456789012:XYZ\n"
"arn:aws:s3:::123456789012-ssp-mfa-tokens/*\n"
"arn:aws:s3:::123456789012-ssp-mfa-tokens\n\n"
"arn:aws:iam::123456789012:user/Development/product_1234/*\n"
"arn:aws:iam::123456789012:root\n"
"arn:aws:iam::123456789012:user/JohnDoe\n"
"arn:aws:iam::123456789012:user/division_abc/subdivision_xyz/JaneDoe\n"
"arn:aws:iam::123456789012:group/Developers\n"
"arn:aws:iam::123456789012:group/division_abc/subdivision_xyz/product_A/Developers\n"
"arn:aws:iam::123456789012:role/S3Access\n"
"arn:aws:iam::123456789012:role/application_abc/component_xyz/RDSAccess\n"
"arn:aws:iam::123456789012:role/aws-service-role/access-analyzer.amazonaws.com/AWSServiceRoleForAccessAnalyzer\n"
"arn:aws:iam::123456789012:role/service-role/QuickSightAction\n"
"arn:aws:iam::123456789012:policy/UsersManageOwnCredentials\n"
"arn:aws:iam::123456789012:policy/division_abc/subdivision_xyz/UsersManageOwnCredentials\n"
"arn:aws:iam::123456789012:instance-profile/Webserver\n"
"arn:aws:sts::123456789012:federated-user/JohnDoe\n"
"arn:aws:sts::123456789012:assumed-role/Accounting-Role/JaneDoe\n"
"arn:aws:iam::123456789012:mfa/JaneDoeMFA\n"
"arn:aws:iam::123456789012:u2f/user/JohnDoe/default (U2F security key)\n"
"arn:aws:iam::123456789012:server-certificate/ProdServerCert\n"
"arn:aws:iam::123456789012:server-certificate/division_abc/subdivision_xyz/ProdServerCert\n"
"arn:aws:iam::123456789012:saml-provider/ADFSProvider\n"
"arn:aws:iam::123456789012:oidc-provider/GoogleProvider\n\n"
"arn:partition:service:region:account-id:resource-id\n"
"arn:partition:service:region:account-id:resource-type/resource-id\n"
"arn:partition:service:region:account-id:resource-type:resource-id")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")