import Foundation
let pattern = #"(\d+:\d+:\d+) \+running (\w+)(?:(?:.(?!\d+:\d+:\d+))*\n(\d+:\d+:\d+) \-running)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
00:00:00 +running A
dummy data
00:00:01 -running
00:00:02 +running B
dummy data
00:00:03 +running B
00:00:04 -running
00:00:05 +running C
dummy data
00:00:06 -running
00:00:07 +running D
10:00:08 -running
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)