import re
regex = re.compile(r"(?<=.).(?=[^@]*?.@)|(?:(?<=@.)|(?!^)\G(?=[^@]*$))(.)(?=.*\.)|(?:(?<=\.)(?=[^.]+$)|(?!^)\G(?=[^@.]*$))[^.](?!$)", flags=re.MULTILINE)
test_str = "john.travolta@gmail.com"
subst = "*"
result = regex.sub(subst, test_str)
if result:
print(result)