re = /((?<=^|\s)[a-z])|([a-z](?:$|\s))/
str = ' ddewd how can mirrors be real if our eyes aren\'t real'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end