$re = '/\[(.*),(.*)\]/';
$str = 'Points: [x1,y1] and [x2,y2]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);