$re = '/^[XYZ]?([0-9]{7,8})([A-Z])$/i';
$str = '85391338C
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);