$re = '/^\s+|\s+$/';
$str = ' this is something ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;