$re = '/(?<=[^@]\{)[^\}]*(?=\})/';
$str = '{eww}
r23r23{fetwe}
@{d2dded}
#{d2dded}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);