package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Z][a-z]+, [A-Z][a-z]*\.`)
var str = `Neil, Gogte." and "Satyam, B.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}