$re = '/^([a-zA-Z_\-]+\h)*([a-zA-Z_\-]+$)/m';
$str = 'abd d
a bdc
abd de
ab cde';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);