#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)S.+(?=, [^S])"
Local $sString = "(Last name) (First name)" & @CRLF & _
"Duncan, Jean" & @CRLF & _
"Schmidt, Paul" & @CRLF & _
"Sells, Simon" & @CRLF & _
"Martin, Jane" & @CRLF & _
"Smith, Peter" & @CRLF & _
"Stephens, Sheila" & @CRLF & _
"Schmidt, P " & @CRLF & _
"Smith, P"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")