$re = '/^(0|[1-9]{1}\d{0,7})(\.{1}\d{1,4}?)?$/';
$str = '0.001';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);