import re
regex = re.compile(r"^(([a-zA-Z]|[0-9])|([-]|[_]|[.]))+[@](([a-zA-Z0-9])|([-])){2,63}[.](([a-zA-Z0-9]){2,63})+$")
test_str = "alainsouchet@smile.fr"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)