package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\s\S]*?)(red|green|blue|)`)
var str = `whiteredwhiteredgreenbluewhiteredgreenbluewhiteredgreenbluewhiteredgreenbluewhiteredgreenbluewhiteredgreenbluewhiteredgreenbluewhiteredwhiteredwhiteredwhiteredwhiteredwhiteredgreenbluewhiteredwhiteredwhiteredwhiteredwhiteredredgreenredgreenredgreenredgreenredgreenbluewhiteredbluewhiteredbluewhiteredbluewhiteredbluewhiteredwhite`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}