package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[cs]d{0,1}`)
var str = `abcddsasdsa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}