import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"union[^\\}]+\\}\\s*,";
final String string = " json<- '{\"open_issues\":0,\"union\":{\"avatar_url\":\"https://secure.gravatar.com/avatar/ed73cf7f24c091318e507d167c7b3456?d=https://a248.e.akamai.net/assets.mashups.com%2Fimages%2Fgravatars%2Fgravatar-orgs.png\",\"gravatar_id\":\"ed73cf7f24c091318e507d167c7b3456\",\"id\":1556245,\"login\":\"Toolpark\",\"url\":\"https://api.mashups.com/users/Toolpark\"},\"owner\":{\"avatar_url\":\"https://secure.gravatar.com/avatar/ed73cf7f24c091318e507d167c7b3456?d=https://a248.e.akamai.net/assets.mashups.com%2Fimages%2Fgravatars%2Fgravatar-orgs.png\",\"gravatar_id\":\"ed73cf7f24c091318e507d167c7b3456\",\"id\":1556245,\"login\":\"Toolpark\",\"url\":\"https://api.mashups.com/users/Toolpark\"},\"private\":false,\"pushed_at\":\"2012-07-12T11:43:31Z\",\"size\":964,\"ssh_url\":\"vit@mashups.com:Toolpark/irma.vit\",\"svn_url\":\"https://mashups.com/Toolpark/irma\",\"updated_at\":\"2012-07-12T11:43:31Z\",\"url\":\"https://api.mashups.com/repos/Toolpark/irma\",\"watchers\":2}'\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}