import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^\\s*([+-])?|\\s*(?<![+-])([+-]))\\s*(?:(\\d+(?:\\.\\d*)?)\\s*\\*)?\\s*(?<![+-])([+-])?(\\d+(?:\\.\\d*)?)?([xX])?(?:\\^(\\d+))?\\s*";
final String string = "5 + 4 * X + X^2 - 2 + X^2 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}