$re = '/^[\w~!@#\$-]+$/m';
$str = 'ab@4_w
sd!tye123
sd%tye123
sd*tye123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);