#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?!.*[\!\@\#\$\%\^\&\*\(\)\[\]\{\}\`\~\|\\\/\?\>\<\.\,\:\;\'\"]).{1,20}"
Local $sString = "a0A"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")