import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[^ \\t\\*\\n\\|]+)|((?<=^\\|)\\s+[^ \\t\\*\\n\\|]+)";
final String string = "Scenario Outline: Eating\n"
+ " Given there are <start> cucumbers\n"
+ " When I eat <eat> cucumbers\n"
+ " Then I should have <left> cucumbers\n\n"
+ " Examples:\n"
+ " | start | eat | left |\n"
+ " | 12 | 5 | 7 |\n"
+ " | 20 | 5 | 15 |";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}