import re
regex = re.compile(r"[\w\d]+(?=[\W])|([\d\w]+)")
test_str = "567* hELLO 565 this is >>>>> a special ads special sy3mbol || 999999* fgdg"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")