#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{2}\/\d{2}\/\d{4}),\s(\d(?:\d)?:\d{2})\s-\s([^:]*):\s(.*?)(?=\s*\d{2}\/|$)"
Local $sString = " 09/05/2016, 13:11 - Joe Bloggs: Hey Jane how're you doing? ? what dates are you in London again? I realise that June isn't actually that far away so might book my trains down sooner than later!" & @CRLF & _
"09/05/2016, 13:47 - Jane Doe: Hey! I'm in london from the 12th-16th of june! Hope you can make it down :) sorry it's a bit annoying i couldn't make it there til a sunday!" & @CRLF & _
"09/05/2016, 14:03 - Joe Bloggs: Right I'll speak to my boss! I've just requested 5 weeks off in November/December to visit Aus so I'll see if I can negotiate some other days!" & @CRLF & _
"" & @CRLF & _
"When does your uni term end in November? I'm thinking of visiting perth first then going to the east coast!" & @CRLF & _
"09/05/2016, 22:32 - Jane Doe: Oh that'll be awesome if you come to aus! Totally understand if it's too hard for you to request more days off in june. " & @CRLF & _
"" & @CRLF & _
"I finish uni early November! So should definitely be done by then if you came here" & @CRLF & _
"09/05/2016, 23:20 - Joe Bloggs: I could maybe get a couple of days ? when do you fly into London on the Sunday?" & @CRLF & _
"" & @CRLF & _
"Perfect! I need to speak to everyone else to make sure they're about. I can't wait to visit but it's so far away!" & @CRLF & _
"09/05/2016, 23:30 - Jane Doe: I fly in at like 7.30am so I'll have that whole day!" & @CRLF & _
"" & @CRLF & _
"I'm sure the year will fly since it's may already haha" & @CRLF & _
"09/05/2016, 23:34 - Joe Bloggs: Aw nice one! Even if I can get just Monday off I can get an early train on Sunday ?" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")