$re = '/^(?!.*[A-Z]{11})/m';
$str = '1AAAAAAAAAA
2AAAAAAAAAA
3AAAAAAAAAAB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);