re = /(?<=INICIO).*?(INICIO.*?FIM)|(?<=FIM).*?(INICIO.*?FIM)/m
str = 'JJJJJJJJJJJJJJJINICIOAAAAAAAAAAAAINICIOBBBBBBBBBBBBFIMJJJJJJJJJJJJJJINICIOJJJJJJJJJJJJJJFIMINICIOCCCCCCCCCCFIM'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end