$re = '/(?<!\.min)\.(js|css)$/m';
$str = 'foo.js
bar.css
foo.min.js
bar.min.css';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);