// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)https?:\/\/(?:www\.)?([-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z]{2,6}\b)*(\/[\/\d\w\.-]*)*(?:[\?])*(.+)*").unwrap();
let string = "https://www.asd.google.com/search?q=some+text¶m=3#dfsdf
https://www.google.com
http://google.com/?q=some+text¶m=3#dfsdf
https://www.google.com/api/?
https://www.google.com/api/login.php";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}