package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(\d{3}\)(-| )\d{3}(-|\s)\d{4}`)
var str = `(514)-381-6273
(514) 284-3145
(514) 231-1341`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}