$re = '@\w+/\w+/(\w+)/@';
$str = 'X/0/12/34/5678/9';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);