package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{![a-zA-Z0-9_.]*}`)
var str = `{!Customobject_relateobject.name}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}