package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*(\/).*?\/$`)
var str = `http://localhost:8888/alain-pers/fr/oeuvres/architecture/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}