package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)PJSIP/(\d+)\S+ Up ([\d:]+).+?<(\d+)>`)
var str = `Channel: Exten: CLCID: ========================================================================================== Channel: PJSIP/739-00009cf3/Dial Up 00:01:15 Exten: s CLCID: "CID:9622088888" <79379853222> Channel: PJSIP/814-00009cf5/Dial Up 00:00:25 Exten: s CLCID: "CID:9622088888" <89119120799> Channel: PJSIP/BEELINE_9622088888-00009cf4/AppDial Up 00:01:13 Exten: CLCID: "" <9622088888> Channel: PJSIP/BEELINE_9622088888-00009cf6/AppDial Up 00:00:25 Exten: CLCID: "" <9622088888> Objects found: 4
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}