use strict;
my $str = '"87",0000,0767,"078",0785,"0723",23487, "061 904 5284","17\\/10\\/2016","some.name.789@hotmail.com"';
my $regex = qr/(?<!")(\b\d+\b)(?!")/p;
my $subst = '"$1"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";