const regex = /MINISTÉRIO[\s\S]*?PÁG/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('MINISTÉRIO[\\s\\S]*?PÁG', '')
const str = `MINISTÉRIO
text
PÁG`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}