$re = '/MINISTÉRIO[^P]*(?:P(?!ÁG)[^P]*)*PÁG/';
$str = 'MINISTÉRIO
text
PÁG';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);