package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\)(\s*)\(`)
var str = `(A : 200) (B : 1140) (B : 1140)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}