$re = '/-?\d+(\.\d+)?/m';
$str = '20105
-10005
10.25';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);