import re
regex = re.compile(r"/\.(?=/)", flags=re.MULTILINE)
test_str = "c:/create/a/dir/very/deep/inside/../././../../../dir/"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)