$re = '/the (?:(?!the).)+? area/';
$str = '"A popular resource for the Christian community in the Asheville area."
"I love the acting community in the Orange County area."';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);