$re = '/(?ms)Client logging in as (?<user_failed_login>[^ ]*).*(failed|ERROR)/';
$str = ' 017/09/25 10:58:57 Client logging in as robertE on DB1...
Connect to Oracle failed:
ORA-01017: invalid username/password; logon denied
ERROR:User login failed!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);