package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b((25[0-5]|2[0-4]\d|[01]?\d\d?)\.){3}(25[0-5]|2[0-4]\d|[01]?\d\d?)\b`)
var str = `255.255.255.0
0.0.0.0
256.0.0.1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}