package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d*\.?\d+\s?KV)`)
var str = `asd1 12KVsdf
pqr 11.2 KVsdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}