$re = '/(\d{2}\/\d{2}\/\d{2}),\s(\d{1,2}:\d{2}(?:\s(?:AM|PM)))?\s-\s(.*):\s(.*)/';
$str = '02/05/16, 12:05 AM - +91 00580 00000: Hello
02/05/16, 12:06 AM - Ross Clark: Hello there!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);