$re = '/(?<=@)([^\s]+)(?=\s|$)/';
$str = 'nicky@nike.com
nicky@nike-affiliates.com
nicky@somesite.co.uk and some words for whatever reason';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);