$re = '/\b\d+(?!nd|st)\b/';
$str = '50th red balloon
11 red balloons';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);