$re = '/(?:\\\\"[^"\\\\]*\\\\"|[^\s\\\\"])+/';
$str = 'name=\\"Student one\\" grade=\\"fifth grade\\" gender=m place=\\"some place in this earth\\" dob=30/02/1900 enrolled';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);