const regex = /^0*([1-9]?\d|1\d\d|2[0-4]\d|25[0-5])\.0*([1-9]?\d|1\d\d|2[0-4]\d|25[0-5])\.0*([1-9]?\d|1\d\d|2[0-4]\d|25[0-5])\.0*(([1-9]?\d|1\d\d|2[0-4]\d|25[0-5])|(([1-9]?\d|1\d\d|2[0-4]\d|25[0-5])(\/([1-9]?\d|1\d\d|2[0-4]\d|25[0-5]))))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0*([1-9]?\\d|1\\d\\d|2[0-4]\\d|25[0-5])\\.0*([1-9]?\\d|1\\d\\d|2[0-4]\\d|25[0-5])\\.0*([1-9]?\\d|1\\d\\d|2[0-4]\\d|25[0-5])\\.0*(([1-9]?\\d|1\\d\\d|2[0-4]\\d|25[0-5])|(([1-9]?\\d|1\\d\\d|2[0-4]\\d|25[0-5])(\\\/([1-9]?\\d|1\\d\\d|2[0-4]\\d|25[0-5]))))$', 'gm')
const str = `1.1.1.142
128.12.34.9
0.0.0.0/128
1.1.1.1
13.23.76.90/128`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}