$re = '/((?:\d+\.){3}\d+)(?=:\d+)/';
$str = '{
"auth" : {
"login" : "http://123.123.11.22:85/auth/signin",
"resetpass" : "http://123.123.22.33:85/auth/resetpass",
"profile" : "http://123.123.33.44:85/auth/profile"
}
}';
$subst = "mydomain";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;