$re = '/[\w.].*[\w.]/x';
$str = '@#%%.Hol$a.A.$%';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);