import re
regex = re.compile(r"((http:)[A-Z0-9a-z\.\/]*(\.mp3))")
test_str = "<div class=\"rp-playlist-top-delimiter\"></div><div tabindex=\"0\" style=\"overflow: hidden; padding: 0px; width: 612px; outline: medium none;\" class=\"rp-playlist jspScrollable\"><div style=\"width: 612px; height: 620px;\" class=\"jspContainer\"><div style=\"padding: 0px; width: 592px; top: 0px;\" class=\"jspPane\"><ul class=\"rp-playlist-list\"><li class=\"rp-playlist-item current\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 07/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.01</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 07/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.01\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45927313.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 08/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.02</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 08/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.02\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45927312.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 09/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.03</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 09/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.03\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45927301.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 14/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.04</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 14/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.04\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45927300.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.05</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.05\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45927297.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 15/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.06</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 15/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.06\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45927299.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.07</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.07\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45927294.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 16/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.08</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 16/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.08\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45927293.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 17/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.09</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 17/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.09\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45927292.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 21/09/2015 - ELCRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.10</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 21/09/2015 - ELCRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.10\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45931700.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 22/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.11</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 22/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.11\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45931736.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 23/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.12</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 23/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.12\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45931707.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.13</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.13\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45931704.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 24/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.14</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 24/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.14\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45939800.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 25/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.15</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 25/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.15\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45943610.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 25/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.16</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 25/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.16\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45943694.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 28/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.17</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 28/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.17\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45944386.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 29/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.18</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 29/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.18\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45944381.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 30/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.19</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 30/09/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.19\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45944380.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 01/10/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.20</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 01/10/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.20\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45944378.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 05/10/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.21</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 05/10/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.21\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45950630.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 06/10/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.22</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 06/10/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.22\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45950889.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 07/10/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.23</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 07/10/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.23\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45950888.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 08/10/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.24</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 08/10/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.24\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45950878.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li><li class=\"rp-playlist-item last\"><div class=\"rp-playlist-item-content\"><div class=\"rp-playlist-item-title clickable\">AD ALTA VOCE del 09/10/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.25</div><a class=\"rss-item-download\" data-title=\"AD ALTA VOCE del 09/10/2015 - CRISTO SI E' FERMATO A EBOLI DI CARLO LEVI P.25\" onclick=\"javascript: window.player_init.url='http://www.radio.rai.it/podcast/A45950877.mp3'; window.titolo=$(this).attr('data-title');downloadaudiopodcast(); return false;\" href=\"#\"></a></div></li></ul></div><div class=\"jspVerticalBar\"><div class=\"jspCap jspCapTop\"></div><div style=\"height: 620px;\" class=\"jspTrack\"><div style=\"height: 175px; top: 0px;\" class=\"jspDrag\"><div class=\"jspDragTop\"></div><div class=\"jspDragBottom\"></div></div></div><div class=\"jspCap jspCapBottom\"></div></div></div></div><div class=\"boxCommenti\" data-uniquename=\"ContentItem-6f9636cc-4d39-414c-92a2-88b517cab226\" data-url=\"http://www.rai.tv/dl/RaiTV/programmi/media/ContentItem-6f9636cc-4d39-414c-92a2-88b517cab226.html\">"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")