const regex = /.\d{2}:\d{2}:\d{2}[.]\d{3}[Z]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.\\d{2}:\\d{2}:\\d{2}[.]\\d{3}[Z]', '')
const str = `2014-05-17T07:26:45.453Z`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}